Constructs an instance of ThermalAsset.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ThermalAsset(
string name,
ThermalMaterialType materialType
)
Public Sub New (
name As String,
materialType As ThermalMaterialType
)
public:
ThermalAsset(
String^ name,
ThermalMaterialType materialType
)
new :
name : string *
materialType : ThermalMaterialType -> ThermalAsset
Parameters
- name String
-
The name of the asset.
- materialType ThermalMaterialType
-
The type of thermal material that this asset will describe.
ExceptionsException | Condition |
---|
ArgumentException |
name is an empty string.
-or-
name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~".
|
ArgumentNullException |
A non-optional argument was null
|
ArgumentOutOfRangeException |
A value passed for an enumeration argument is not a member of that enumeration
|
See Also