VisibleInViewFilter(Document, ElementId, Boolean) Constructor |
Constructs a new instance of a VisibleInViewFilter, with the option to pass all non-visible elements.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic VisibleInViewFilter(
Document document,
ElementId viewId,
bool inverted
)
Public Sub New (
document As Document,
viewId As ElementId,
inverted As Boolean
)
public:
VisibleInViewFilter(
Document^ document,
ElementId^ viewId,
bool inverted
)
new :
document : Document *
viewId : ElementId *
inverted : bool -> VisibleInViewFilter
Parameters
- document Document
-
The document that owns the view.
- viewId ElementId
-
The view id.
- inverted Boolean
-
True if the filter should match all elements not visible in the given view.
ExceptionsException | Condition |
---|
ArgumentException |
viewId is not a view.
-or-
viewId is not valid for element iteration, because it has no way of representing drawn elements. Many view templates
will fail this check.
|
ArgumentNullException |
A non-optional argument was null
|
See Also