BoundaryConditionsGetCurve Method |
Returns curve that define geometry of the line boundary conditions.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
SyntaxPublic Function GetCurve As Curve
public:
Curve^ GetCurve()
member GetCurve : unit -> Curve
Return Value
Curve
ExceptionsException | Condition |
---|
InvalidObjectException |
Thrown when BoundaryConditions is not a BoundaryConditionsType::Line type.
|
Remarks
Boundary conditions should be BoundaryConditionsType::Line type. Otherwise exception is thrown.
See Also