CurveLoopCreateViaThicken(Curve, Double, XYZ) Method

Creates a new closed curve loop by thickening the input curve with respect to a given plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static CurveLoop CreateViaThicken(
	Curve pCurve,
	double thickness,
	XYZ normal
)

Parameters

pCurve  Curve
The input curve.
thickness  Double
The distance between the offset curves created on either side of the input curve.
normal  XYZ
The normal vector to the plane used for thickening.

Return Value

CurveLoop
The new curve loop.
Exceptions
ExceptionCondition
ArgumentException The input thickness is too short for a curve. -or- The input pCurve points to a helical curve and is not supported for this operation.
ArgumentNullException A non-optional argument was null
InvalidOperationException Throws if the input curve could not be thickened.
Remarks
The new loop will be created via offsets of the input curve (in the plane of the normal vector) with the endpoints connected with lines.The original curve will be at the center of the new loop.

Note that for input elliptical fragments and NurbSpline curves, any offsets will be created as HermiteSplines.

See Also