HostObjectFindInserts Method |
Gets the ids of the instances inserted into this host object.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IList<ElementId> FindInserts(
bool addRectOpenings,
bool includeShadows,
bool includeEmbeddedWalls,
bool includeSharedEmbeddedInserts
)
Public Function FindInserts (
addRectOpenings As Boolean,
includeShadows As Boolean,
includeEmbeddedWalls As Boolean,
includeSharedEmbeddedInserts As Boolean
) As IList(Of ElementId)
public:
IList<ElementId^>^ FindInserts(
bool addRectOpenings,
bool includeShadows,
bool includeEmbeddedWalls,
bool includeSharedEmbeddedInserts
)
member FindInserts :
addRectOpenings : bool *
includeShadows : bool *
includeEmbeddedWalls : bool *
includeSharedEmbeddedInserts : bool -> IList<ElementId>
Parameters
- addRectOpenings Boolean
-
True if rectangular openings should be included in the return.
- includeShadows Boolean
-
True if shadows should be included in the return.
- includeEmbeddedWalls Boolean
-
True if embedded walls should be included in the return.
- includeSharedEmbeddedInserts Boolean
-
True if shared embedded inserts should be included in the return.
Return Value
IListElementId
All the insertable instances' ids.
See Also