FamilyInstancePlacingArgs Class

The class is used to access necessary data during the placement of a FamilyInstance.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.UIFamilyInstancePlacingArgs

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FamilyInstancePlacingArgs : IDisposable

The FamilyInstancePlacingArgs type exposes the following members.

Properties
 NameDescription
Public propertyActiveView The active view
Public propertyIsBanned Indicates if the cursor is banned or not.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyStatusMessage The message to be shown on the status bar
Public propertyTooltipMessage The message to be shown via tooltip
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the FamilyInstancePlacingArgs
Top
See Also