ScheduleDefinitionInsertField(SchedulableField, Int32) Method |
Adds a regular field at the specified position in the list.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ScheduleField InsertField(
SchedulableField schedulableField,
int index
)
Public Function InsertField (
schedulableField As SchedulableField,
index As Integer
) As ScheduleField
public:
ScheduleField^ InsertField(
SchedulableField^ schedulableField,
int index
)
member InsertField :
schedulableField : SchedulableField *
index : int -> ScheduleField
Parameters
- schedulableField SchedulableField
-
A SchedulableField object representing the field.
- index Int32
-
The index in the list of fields.
Return Value
ScheduleField
The new field.
ExceptionsException | Condition |
---|
ArgumentException |
The field specified by schedulableField may not included in this ScheduleDefinition.
-or-
The field specified by schedulableField is already included in this ScheduleDefinition.
|
ArgumentNullException |
A non-optional argument was null
|
ArgumentOutOfRangeException |
index is not a valid insert position.
|
See Also