AreaLoadIsCurveLoopsInsideHostBoundaries Method |
Checks if contour loops is inside host boundaries.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool IsCurveLoopsInsideHostBoundaries(
Document doc,
ElementId hostId,
IList<CurveLoop> loops
)
Public Shared Function IsCurveLoopsInsideHostBoundaries (
doc As Document,
hostId As ElementId,
loops As IList(Of CurveLoop)
) As Boolean
public:
static bool IsCurveLoopsInsideHostBoundaries(
Document^ doc,
ElementId^ hostId,
IList<CurveLoop^>^ loops
)
static member IsCurveLoopsInsideHostBoundaries :
doc : Document *
hostId : ElementId *
loops : IList<CurveLoop> -> bool
Parameters
- doc Document
-
Document.
- hostId ElementId
-
The id of the analytical element that is about to host a load
- loops IListCurveLoop
-
CurveLoops to be checked.
Return Value
Boolean
Returns true if area load is positioned with entire distribution over the host, false otherwise.
Exceptions
See Also