AdaptiveComponentFamilyUtilsSetPointOrientationType Method |
Sets orientation type of an Adaptive Placement Point.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static void SetPointOrientationType(
Document doc,
ElementId refPointId,
AdaptivePointOrientationType orientationType
)
Public Shared Sub SetPointOrientationType (
doc As Document,
refPointId As ElementId,
orientationType As AdaptivePointOrientationType
)
public:
static void SetPointOrientationType(
Document^ doc,
ElementId^ refPointId,
AdaptivePointOrientationType orientationType
)
static member SetPointOrientationType :
doc : Document *
refPointId : ElementId *
orientationType : AdaptivePointOrientationType -> unit
Parameters
- doc Document
-
The Document
- refPointId ElementId
-
The ReferencePoint id
- orientationType AdaptivePointOrientationType
-
Orientation type of the Adaptive Placement Point.
ExceptionsException | Condition |
---|
ArgumentException |
The ElementId refPointId does not correspond to a valid ReferencePoint.
-or-
The Element corresponding to ElementId refPointId does not belong to an Adaptive Family.
-or-
The ElementId refPointId does not correspond to an Adaptive Placement Point.
|
ArgumentNullException |
A non-optional argument was null
|
ArgumentOutOfRangeException |
A value passed for an enumeration argument is not a member of that enumeration
|
InvalidOperationException |
This operation failed.
|
See Also