ClassificationEntry Constructor |
Constructs a ClassificationEntry object
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ClassificationEntry(
string key,
string parentKey,
string description,
int level,
ElementId categoryId
)
Public Sub New (
key As String,
parentKey As String,
description As String,
level As Integer,
categoryId As ElementId
)
public:
ClassificationEntry(
String^ key,
String^ parentKey,
String^ description,
int level,
ElementId^ categoryId
)
new :
key : string *
parentKey : string *
description : string *
level : int *
categoryId : ElementId -> ClassificationEntry
Parameters
- key String
-
The key of this ClassificationEntry.
- parentKey String
-
The parent key of this ClassificationEntry.
- description String
-
The description associated with this ClassificationEntry.
- level Int32
-
The level of this ClassficationEntry.
- categoryId ElementId
-
The category id of this ClassificationEntry.
The category can be invalidElementId, otherwise it must represent Revit existing category.
ExceptionsException | Condition |
---|
ArgumentException |
key is an empty string.
-or-
The categoryId is not appropriate category id for classfication entry.
|
ArgumentNullException |
A non-optional argument was null
|
See Also