Creates a new curve loop.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static CurveLoop Create(
IList<Curve> curves
)
Public Shared Function Create (
curves As IList(Of Curve)
) As CurveLoop
public:
static CurveLoop^ Create(
IList<Curve^>^ curves
)
static member Create :
curves : IList<Curve> -> CurveLoop
Parameters
- curves IListCurve
-
The curves.
Return Value
CurveLoop
The curve loop.
ExceptionsException | Condition |
---|
ArgumentException |
The input curves contains at least one helical curve and is not supported for this operation.
-or-
Throws if the input curves are not contiguous.
|
ArgumentNullException |
A non-optional argument was null
|
See Also