ViewIsValidViewTemplate Method |
Verifies that the view represented by templateId can be set as the controlling view template for this view.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsValidViewTemplate(
ElementId templateId
)
Public Function IsValidViewTemplate (
templateId As ElementId
) As Boolean
public:
bool IsValidViewTemplate(
ElementId^ templateId
)
member IsValidViewTemplate :
templateId : ElementId -> bool
Parameters
- templateId ElementId
-
The id to be validated as a view template for this view.
Return Value
Boolean
True if the view is valid for us as a view template and compatible with this view, or if it is InvalidElementId, false otherwise.
Exceptions
See Also