CompoundStructureSetDeckProfileId Method |
Sets the profile loop to use for the specified structural deck.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetDeckProfileId(
int layerIdx,
ElementId profileId
)
Public Sub SetDeckProfileId (
layerIdx As Integer,
profileId As ElementId
)
public:
void SetDeckProfileId(
int layerIdx,
ElementId^ profileId
)
member SetDeckProfileId :
layerIdx : int *
profileId : ElementId -> unit
Parameters
- layerIdx Int32
-
Index of a layer in the CompoundStructure.
- profileId ElementId
-
The element id of a FamilySymbol which contains a profile loop to be used by the specified layer if it is a structural deck.
Exceptions
See Also