ViewGetCategoryHidden Method |
Checks if elements of the given category are set to be invisible (hidden) in this view.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool GetCategoryHidden(
ElementId categoryId
)
Public Function GetCategoryHidden (
categoryId As ElementId
) As Boolean
public:
bool GetCategoryHidden(
ElementId^ categoryId
)
member GetCategoryHidden :
categoryId : ElementId -> bool
Parameters
- categoryId ElementId
-
The ID of the category.
Return Value
Boolean
True if the category is invisible (hidden), false otherwise.
Exceptions
Remarks
This checks only if the category is set visible or invisible individually. Other Revit mechanisms
may also affect the visibility of elements of this category, including:
- The category classes settings for
model categories, annotation categories, import categories or analytical model categories.
- View filters.
- Elements hidden individually in the view.
Thus the return value may not reflect the actual visibility of elements of this category in the view.
See Also