DocumentNewGutter(GutterType, Reference) Method |
Creates a gutter along a reference.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic Gutter NewGutter(
GutterType GutterType,
Reference reference
)
Public Function NewGutter (
GutterType As GutterType,
reference As Reference
) As Gutter
public:
Gutter^ NewGutter(
GutterType^ GutterType,
Reference^ reference
)
member NewGutter :
GutterType : GutterType *
reference : Reference -> Gutter
Parameters
- GutterType GutterType
- The type of the gutter to create
- reference Reference
- A planar line or arc that represents the place where you
want to place the gutter.
Return Value
Gutter If successful a new gutter object within the project, otherwise
.
ExceptionsException | Condition |
---|
ArgumentException | Thrown if the gutter type does not exist in the given document. |
See Also