MechanicalSystemCreate(Document, ElementId) Method |
Creates a new instance of a mechanical system and adds it to the document.
Namespace: Autodesk.Revit.DB.MechanicalAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static MechanicalSystem Create(
Document ADocument,
ElementId typeId
)
Public Shared Function Create (
ADocument As Document,
typeId As ElementId
) As MechanicalSystem
public:
static MechanicalSystem^ Create(
Document^ ADocument,
ElementId^ typeId
)
static member Create :
ADocument : Document *
typeId : ElementId -> MechanicalSystem
Parameters
- ADocument Document
-
The document where the element will be created and added.
- typeId ElementId
-
The identifier of this mechanical system element's type.
Return Value
MechanicalSystem
The newly created mechanical system element.
Exceptions
See Also