RebarBendingDetailSetTagRelativePosition Method |
Sets the embedded tag position w.r.t. the realistic bending detail element in model coordinates.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static void SetTagRelativePosition(
Element bendingDetail,
XYZ relativeOffset
)
Public Shared Sub SetTagRelativePosition (
bendingDetail As Element,
relativeOffset As XYZ
)
public:
static void SetTagRelativePosition(
Element^ bendingDetail,
XYZ^ relativeOffset
)
static member SetTagRelativePosition :
bendingDetail : Element *
relativeOffset : XYZ -> unit
Parameters
- bendingDetail Element
-
The bending detail element.
- relativeOffset XYZ
-
The new relative position of the embedded tag w.r.t. the bending detail element.
ExceptionsException | Condition |
---|
ArgumentException |
This option is only available for realistic bending detail elements.
-or-
The input point lies outside of Revit design limits.
|
ArgumentNullException |
A non-optional argument was null
|
Remarks
This function is exclusive to realistic bending detail mode.
See Also