FlexPipeIsFlexPipeTypeId Method |
Checks if given type is valid flexible pipe type.
Namespace: Autodesk.Revit.DB.PlumbingAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool IsFlexPipeTypeId(
Document document,
ElementId pipeTypeId
)
Public Shared Function IsFlexPipeTypeId (
document As Document,
pipeTypeId As ElementId
) As Boolean
public:
static bool IsFlexPipeTypeId(
Document^ document,
ElementId^ pipeTypeId
)
static member IsFlexPipeTypeId :
document : Document *
pipeTypeId : ElementId -> bool
Parameters
- document Document
-
The document.
- pipeTypeId ElementId
-
ElementId of the flexible pipe type to check.
Return Value
Boolean
True if flexible pipe type can used for this pipe, false otherwise.
Exceptions
Remarks
A type is valid for flexible pipe if it can be used to the flexible pipe element.
See Also