FamilyManagerSet(FamilyParameter, ElementId) Method |
Set the ElementId value of a family parameter of the current family type.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void Set(
FamilyParameter familyParameter,
ElementId value
)
Public Sub Set (
familyParameter As FamilyParameter,
value As ElementId
)
public:
void Set(
FamilyParameter^ familyParameter,
ElementId^ value
)
member Set :
familyParameter : FamilyParameter *
value : ElementId -> unit
Parameters
- familyParameter FamilyParameter
- A family parameter of the current type.
- value ElementId
- The new value for family parameter.
ExceptionsException | Condition |
---|
ArgumentException |
Thrown when the storage type of family parameter is not ElementId --or-- The input ElementId does not represent either a valid element in the document or InvalidElementId.
|
ArgumentOutOfRangeException |
Thrown when the input ElementId is not valid as a value for this FamilyParameter.
|
InvalidOperationException |
Thrown when the family parameter is determined by formula,
or the current family type is invalid.
|
See Also