FormUtilsDissolveForms(Document, ICollectionElementId, ICollectionElementId) Method |
Dissolves a collection of form elements into their defining elements.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static ICollection<ElementId> DissolveForms(
Document ADoc,
ICollection<ElementId> elements,
out ICollection<ElementId> ProfileOriginPointSet
)
Public Shared Function DissolveForms (
ADoc As Document,
elements As ICollection(Of ElementId),
<OutAttribute> ByRef ProfileOriginPointSet As ICollection(Of ElementId)
) As ICollection(Of ElementId)
public:
static ICollection<ElementId^>^ DissolveForms(
Document^ ADoc,
ICollection<ElementId^>^ elements,
[OutAttribute] ICollection<ElementId^>^% ProfileOriginPointSet
)
static member DissolveForms :
ADoc : Document *
elements : ICollection<ElementId> *
ProfileOriginPointSet : ICollection<ElementId> byref -> ICollection<ElementId>
Parameters
- ADoc Document
-
The document
- elements ICollectionElementId
-
A collection of element IDs of Forms and GeomCombinations that contain Forms that will be dissolved.
- ProfileOriginPointSet ICollectionElementId
-
A collection of the point element ids that represent the 'origin' of the profiles
Return Value
ICollectionElementId
A collection of curve element ids from the profiles and paths of the dissolved forms.
Exceptions
Remarks
Profile origin points define the workplane of form profiles and paths and their curves.
The profile origin point represents a coordinate system with an origin (reference point) which
can be manipulated to move the curves of a profile together as a unit after dissolve.
Profile origin points may themselves be constrained to other parts of the model or parts of the form,
based on how the form was created/constructed. This is done through the reference point hosting
mechanism.
See Also