RebarContainerItemRebarShapeId Property |
The RebarShape element that defines the shape of the rebar.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementId RebarShapeId { get; set; }
Public Property RebarShapeId As ElementId
Get
Set
public:
property ElementId^ RebarShapeId {
ElementId^ get ();
void set (ElementId^ value);
}
member RebarShapeId : ElementId with get, set
Property Value
ElementId
ExceptionsException | Condition |
---|
ArgumentException |
When setting this property: shapeId is not the id of a RebarShape in the document.
-or-
When setting this property: The RebarShape has End Treatments
|
ArgumentNullException |
When setting this property: A non-optional argument was null
|
Remarks
Changing the value of this property causes the Rebar instance to choose values for its
shape parameters to preserve its previous shape as closely as possible
See Also