CompoundStructureGetSegmentEndPoints Method |
Gets the end points of a segment.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void GetSegmentEndPoints(
int segmentId,
int regionId,
out UV end1,
out UV end2
)
Public Sub GetSegmentEndPoints (
segmentId As Integer,
regionId As Integer,
<OutAttribute> ByRef end1 As UV,
<OutAttribute> ByRef end2 As UV
)
public:
void GetSegmentEndPoints(
int segmentId,
int regionId,
[OutAttribute] UV^% end1,
[OutAttribute] UV^% end2
)
member GetSegmentEndPoints :
segmentId : int *
regionId : int *
end1 : UV byref *
end2 : UV byref -> unit
Parameters
- segmentId Int32
-
The segment id.
- regionId Int32
-
The region id.
- end1 UV
-
One end point.
- end2 UV
-
The other end point.
Exceptions
See Also