MEPAnalyticalConnectionCreateMultipleConnections Method |
Creates new analytical connections between the equipment connector and the nearest point on the curves.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static ISet<ElementId> CreateMultipleConnections(
Document doc,
ElementId typeId,
IList<Connector> equipmentOpenConnectors,
IList<ElementId> curveIdsToConnect
)
Public Shared Function CreateMultipleConnections (
doc As Document,
typeId As ElementId,
equipmentOpenConnectors As IList(Of Connector),
curveIdsToConnect As IList(Of ElementId)
) As ISet(Of ElementId)
public:
static ISet<ElementId^>^ CreateMultipleConnections(
Document^ doc,
ElementId^ typeId,
IList<Connector^>^ equipmentOpenConnectors,
IList<ElementId^>^ curveIdsToConnect
)
static member CreateMultipleConnections :
doc : Document *
typeId : ElementId *
equipmentOpenConnectors : IList<Connector> *
curveIdsToConnect : IList<ElementId> -> ISet<ElementId>
Parameters
- doc Document
-
The document where the new elements are created.
- typeId ElementId
-
The type of new analytical connections.
- equipmentOpenConnectors IListConnector
-
The open equipment connectors to be analytically connected.
- curveIdsToConnect IListElementId
-
The curves which the equipment is connected to.
Return Value
ISetElementId
The new analytical connection elements.
ExceptionsException | Condition |
---|
ArgumentException |
Invalid connection type.
-or-
Not all connectors support the analytical connection.
-or-
No connector included.
-or-
Not all elements are valid curve ids.
-or-
No curve included.
|
ArgumentNullException |
A non-optional argument was null
|
See Also