SelectableInViewFilter Class

A filter that passes elements that are selectable in the given view.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElementFilter
    Autodesk.Revit.DBElementSlowFilter
      Autodesk.Revit.UI.SelectionSelectableInViewFilter

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class SelectableInViewFilter : ElementSlowFilter

The SelectableInViewFilter type exposes the following members.

Constructors
 NameDescription
Public methodSelectableInViewFilter(Document, ElementId) Constructs a new instance of an SelectableInViewFilter.
Public methodSelectableInViewFilter(Document, ElementId, Boolean) Constructs a new instance of an SelectableInViewFilter, with the option to pass all non-selectable elements.
Top
Properties
 NameDescription
Public propertyInverted True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted.
(Inherited from ElementFilter)
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from ElementFilter)
Top
Methods
 NameDescription
Public methodDispose
(Inherited from ElementFilter)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodPassesFilter(Element) Applies the filter to a given element.
(Inherited from ElementFilter)
Public methodPassesFilter(Document, ElementId) Applies the filter to a given element.
(Inherited from ElementFilter)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
This filter is a slow filter. Slow filters require that the Element be obtained and expanded in memory first. Thus it is preferable to couple this filter with at least one ElementQuickFilter, which should minimize the number of Elements that are expanded. This filter is designed to operate on a list of elements visible in the given view. This can be obtained from a FilteredElementCollector constructed with the view id. This filter may not correctly restrict elements which are not a part of the visible elements of the view.
See Also