ApplicationNewGeometryOptions Method |
Creates an object to specify user preferences in parsing of geometry.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic Options NewGeometryOptions()
Public Function NewGeometryOptions As Options
public:
Options^ NewGeometryOptions()
member NewGeometryOptions : unit -> Options
Return Value
Options
ExampleAutodesk.Revit.DB.Options geomOption = application.Create.NewGeometryOptions();
if (null != geomOption)
{
geomOption.ComputeReferences = true;
geomOption.DetailLevel = Autodesk.Revit.DB.ViewDetailLevel.Fine;
TaskDialog.Show("Revit", "Geometry Option created successfully.");
}
Dim geomOption As Autodesk.Revit.DB.Options = application.Create.NewGeometryOptions()
If geomOption IsNot Nothing Then
geomOption.ComputeReferences = True
geomOption.DetailLevel = Autodesk.Revit.DB.ViewDetailLevel.Fine
TaskDialog.Show("Revit", "Geometry Option created successfully.")
End If
No code example is currently available or this language may not be supported.
No code example is currently available or this language may not be supported.
See Also