DuctPressureDropDataLevel Property |
The calculation level of the system.
Namespace: Autodesk.Revit.DB.MechanicalAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic SystemCalculationLevel Level { get; }
Public ReadOnly Property Level As SystemCalculationLevel
Get
public:
property SystemCalculationLevel Level {
SystemCalculationLevel get ();
}
member Level : SystemCalculationLevel with get
Property Value
SystemCalculationLevel
Remarks
If the calculation level is Flow, all parameters that need friction will be displayed as "Not Computed" in Properties dialog (Friction, Pressure Drop, Loss Coefficient).
If the calculation level is None, all parameters that need flow will be displayed as "Not Computed" in Properties dialog (Velocity, Velocity Pressure, Reynolds number, Friction, Pressure Drop, Loss Coefficient).
If the calculation level is All, all parameters will be displayed with their actual values in Properties dialog.
See Also