SystemCalculationLevel Enumeration |
Enumerated type listing flags that can toggle on or off certain calculations related to MEP systems.
Namespace: Autodesk.Revit.DB.MechanicalAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum SystemCalculationLevel
Public Enumeration SystemCalculationLevel
public enum class SystemCalculationLevel
type SystemCalculationLevel
MembersMember name | Value | Description |
---|
None | 0 |
System calculation is off
|
Flow | 1 |
System calculation is only for flow
|
Volume | 2 |
This mode is obsoleted in Revit 2017.
|
Performance | 4 |
This mode is reserved for limiting the system propagation and other performance-boosting options.
Note that the system-related functionalities might be traded off for faster layout capability in large system when this mode is on.
Be careful that this mode is NOT included in the "All" mode.
|
All | -1 |
System calculation is on for everything (with every bit being 1)
|
See Also