ApplicationNewTypeBinding(CategorySet) Method |
Creates a new type binding object containing the categories passed as a parameter.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic TypeBinding NewTypeBinding(
CategorySet categorySet
)
Public Function NewTypeBinding (
categorySet As CategorySet
) As TypeBinding
public:
TypeBinding^ NewTypeBinding(
CategorySet^ categorySet
)
member NewTypeBinding :
categorySet : CategorySet -> TypeBinding
Parameters
- categorySet CategorySet
- A set of categories that will be added to the binding.
Return Value
TypeBindingA new type binding object.
RemarksType binding objects are used for attaching shared parameter definitions to a type
within a category.
See Also