DocumentNewFlexPipe(IListXYZ, FlexPipeType) Method

Adds a new flexible pipe into the document, using a point array and pipe type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public FlexPipe NewFlexPipe(
	IList<XYZ> points,
	FlexPipeType pipeType
)

Parameters

points  IListXYZ
The point array indicating the path of the flexible pipe, including the end points.
pipeType  FlexPipeType
The type of the flexible pipe.

Return Value

FlexPipe
If creation was successful then a new flexible pipe is returned, otherwise an exception with failure information will be thrown.
Exceptions
ExceptionCondition
ArgumentNullException Thrown when the input argument points is .
InvalidOperationException Thrown when the flexible pipe cannot be created or regenerate fails.
ArgumentExceptionThrown if the flexible pipe type does not exist in the given document.
See Also