RebarConstraintFlipSideForClearBarSpacingZeroDistanceConstraint Method

Flips the side on which a RebarConstrainedHandle constrained using clear bar distance with zero offset connects to another Rebar target handle.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void FlipSideForClearBarSpacingZeroDistanceConstraint()
Exceptions
ExceptionCondition
InvalidOperationException RebarConstraint is no longer valid. -or- The RebarConstraint is not of RebarConstraintType 'ToOtherRebar'. -or- The RebarConstraint constrain two Rebar ends. -or- The RebarTargetConstraintType is 'HookBend' or 'BarBend'. -or- The RebarConstraint is not using clear bar distance with zero offset to the target rebar.
Remarks

This is available only for constraints of type ToOtherRebar, using clear bar distance with zero offset.

See Also