RebarConstraintType Enumeration |
The various types of constraints that can be applied to a RebarConstrainedHandle.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum RebarConstraintType
Public Enumeration RebarConstraintType
public enum class RebarConstraintType
MembersMember name | Value | Description |
---|
FixedDistanceToHostFace | 0 |
Handle is constrained to remain a fixed distance from a host Element surface.
|
ToCover | 1 |
Handle is attached to the cover of a host Element surface.
|
ToOtherRebar | 2 |
Handle is attached to a handle on another Rebar Element.
It doesn't matter the style (Standard/Stirrup) of this or the other Rebar element.
|
ToSurface | 3 |
Handle is constrained to a surface.
|
See Also