ApplicationNewXYZ(Double, Double, Double) Method

Creates a XYZ object representing coordinates in 3-space with supplied values.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public XYZ NewXYZ(
	double x,
	double y,
	double z
)

Parameters

x  Double
The first coordinate.
y  Double
The second coordinate.
z  Double
The third coordinate.

Return Value

XYZ
Exceptions
ExceptionCondition
ArgumentException Thrown when setting an infinite number to the X, Y or Z property.
See Also