RebarSpliceTypeUtilsSetStaggerLengthMultiplier Method |
Sets the lap length multiplier value.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static void SetStaggerLengthMultiplier(
Document document,
ElementId rebarSpliceTypeId,
double staggerLengthMultiplier
)
Public Shared Sub SetStaggerLengthMultiplier (
document As Document,
rebarSpliceTypeId As ElementId,
staggerLengthMultiplier As Double
)
public:
static void SetStaggerLengthMultiplier(
Document^ document,
ElementId^ rebarSpliceTypeId,
double staggerLengthMultiplier
)
static member SetStaggerLengthMultiplier :
document : Document *
rebarSpliceTypeId : ElementId *
staggerLengthMultiplier : float -> unit
Parameters
- document Document
-
The document.
- rebarSpliceTypeId ElementId
-
The Rebar Splice Type id.
- staggerLengthMultiplier Double
-
The stagger multiplier value.
ExceptionsException | Condition |
---|
ArgumentException |
The rebarSpliceTypeId doesn't represent a valid Rebar Splice Type. It should be an ElementType of BuiltInCategory.OST_RebarSpliceType category.
|
ArgumentNullException |
A non-optional argument was null
|
ArgumentOutOfRangeException |
The given value for staggerLengthMultiplier must be non-negative.
|
See Also