FrameCanDefineRevitGeometry Method |
Tests whether the supplied Frame object may be used to define a Revit curve or surface.
In order to satisfy the requirements the Frame must be orthonormal
and its origin is expected to lie within the Revit design limits
IsWithinLengthLimits(XYZ).
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool CanDefineRevitGeometry(
Frame frameOfReference
)
Public Shared Function CanDefineRevitGeometry (
frameOfReference As Frame
) As Boolean
public:
static bool CanDefineRevitGeometry(
Frame^ frameOfReference
)
static member CanDefineRevitGeometry :
frameOfReference : Frame -> bool
Parameters
- frameOfReference Frame
-
Frame to be validated.
Return Value
Boolean
True if this Frame may be used as a local frame of reference, false otherwise.
Exceptions
Remarks
Certain Revit curve and surface types are defined using a local frame of reference.
See Also