PointCloudOverridesGetPointCloudScanOverrideSettings(ElementId, String, Document) Method |
Gets override settings assigned to a particular scan within a PointCloudInstance element.
Namespace: Autodesk.Revit.DB.PointCloudsAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic PointCloudOverrideSettings GetPointCloudScanOverrideSettings(
ElementId elementId,
string scanTag,
Document doc
)
Public Function GetPointCloudScanOverrideSettings (
elementId As ElementId,
scanTag As String,
doc As Document
) As PointCloudOverrideSettings
public:
PointCloudOverrideSettings^ GetPointCloudScanOverrideSettings(
ElementId^ elementId,
String^ scanTag,
Document^ doc
)
member GetPointCloudScanOverrideSettings :
elementId : ElementId *
scanTag : string *
doc : Document -> PointCloudOverrideSettings
Parameters
- elementId ElementId
-
Id of the overridden element.
- scanTag String
-
The tag identifying the particular scan within the PointCloudInstance element.
Tags can be obtained from PointCloudInstance via method getScans.
- doc Document
-
Document containing the overridden element.
Return Value
PointCloudOverrideSettings
The override settings assigned to the scan, if present, or a default override settings if nothing was found.
Exceptions
See Also