Checks if given type is valid pipe type.
Namespace: Autodesk.Revit.DB.PlumbingAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool IsPipeTypeId(
Document document,
ElementId pipeTypeId
)
Public Shared Function IsPipeTypeId (
document As Document,
pipeTypeId As ElementId
) As Boolean
public:
static bool IsPipeTypeId(
Document^ document,
ElementId^ pipeTypeId
)
static member IsPipeTypeId :
document : Document *
pipeTypeId : ElementId -> bool
Parameters
- document Document
-
The document.
- pipeTypeId ElementId
-
ElementId of the pipe type to check.
Return Value
Boolean
True if pipe type can used for this pipe, false otherwise.
Exceptions
Remarks
A type is valid for pipe if it can be used to the pipe element.
See Also