UIDocumentPromptToMatchElementType Method |
Prompts the user to select elements to change them to the input type.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void PromptToMatchElementType(
ElementType elementType
)
Public Sub PromptToMatchElementType (
elementType As ElementType
)
public:
void PromptToMatchElementType(
ElementType^ elementType
)
member PromptToMatchElementType :
elementType : ElementType -> unit
Parameters
- elementType ElementType
-
The ElementType applied to selected instances.
ExceptionsException | Condition |
---|
ArgumentNullException |
A non-optional argument was null
|
InvalidOperationException |
This document is not the currently active one.
-or-
Starting a new transaction is not permitted. It could be because
another transaction already started and has not been completed yet,
or the document is in a state in which it cannot start a new transaction.
|
Remarks
This method uses its own transaction, so it's not permitted to be invoked in an active transaction.
In a single invocation, the user can select multiple elements to be modified to the given type, until they finish.
See Also