MassInstanceUtilsGetGrossFloorArea Method |
Get the total occupiable floor area represented by a mass instance.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static double GetGrossFloorArea(
Document document,
ElementId massInstanceId
)
Public Shared Function GetGrossFloorArea (
document As Document,
massInstanceId As ElementId
) As Double
public:
static double GetGrossFloorArea(
Document^ document,
ElementId^ massInstanceId
)
static member GetGrossFloorArea :
document : Document *
massInstanceId : ElementId -> float
Parameters
- document Document
-
The Document.
- massInstanceId ElementId
-
The ElementId of the mass instance.
Return Value
Double
The gross floor area in square feet.
Exceptions
Remarks
The area is computed from the cross sections that are created by intersecting the
associated Levels with the mass instance Geometry.
See Also