DocumentNewGutter(GutterType, ReferenceArray) Method |
Creates a gutter along a reference array.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic Gutter NewGutter(
GutterType GutterType,
ReferenceArray references
)
Public Function NewGutter (
GutterType As GutterType,
references As ReferenceArray
) As Gutter
public:
Gutter^ NewGutter(
GutterType^ GutterType,
ReferenceArray^ references
)
member NewGutter :
GutterType : GutterType *
references : ReferenceArray -> Gutter
Parameters
- GutterType GutterType
- The type of the gutter to create
- references ReferenceArray
- An array of planar lines and arcs that represents the place where you
want to place the gutter.
Return Value
Gutter If successful a new gutter object within the project, otherwise
.
ExceptionsException | Condition |
---|
ArgumentException | Thrown if the gutter type does not exist in the given document. |
See Also