RadialArrayGetOriginalMemberIds Method |
Retrieves the ids for the original elements from which the array was created. These elements form the first item in the array.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic override ICollection<ElementId> GetOriginalMemberIds()
Public Overrides Function GetOriginalMemberIds As ICollection(Of ElementId)
public:
virtual ICollection<ElementId^>^ GetOriginalMemberIds() override
abstract GetOriginalMemberIds : unit -> ICollection<ElementId>
override GetOriginalMemberIds : unit -> ICollection<ElementId>
Return Value
ICollectionElementIdThe original member ids of the Array
RemarksIn the family environment, arrays with count 0 use the original elements as a placeholder item for the first array item. The ids of the original elements from which the array was created are returned even for arrays of count 0.
See Also