RebarShapeDrivenAccessorComputeDrivingCurves Method |
Compute the driving curves.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IList<Curve> ComputeDrivingCurves()
Public Function ComputeDrivingCurves As IList(Of Curve)
public:
IList<Curve^>^ ComputeDrivingCurves()
member ComputeDrivingCurves : unit -> IList<Curve>
Return Value
IListCurve
Returns an empty array if an error is encountered.
Exceptions
Remarks
The driving curves are the ones that appear in rebar sketch
mode. They include lines and arcs that drive the shape, but
exclude fillets and hooks. They always lie in a plane--
if the bar is 3D, these curves are a subset or a projection.
They are also used for shape matching.
See Also