ZoneAddSpaces Method

Add a set of existing spaces to Zone element.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool AddSpaces(
	SpaceSet spaces
)

Parameters

spaces  SpaceSet
The spaces which want to add to zone element.

Return Value

Boolean
If successful the current zone element will add a set of input spaces, otherwise .
Exceptions
ExceptionCondition
ArgumentNullException Thrown when the specified parameter Value is .
InvalidOperationException Thrown when the input spaces cannot be added to current zone element.
See Also