MassLevelDataIsValidConceptualConstructionTypeElement Method |
Checks if the ElementId is an acceptable conceptual construction type ElementId for the MassLevelData (Mass Floor).
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsValidConceptualConstructionTypeElement(
ElementId id
)
Public Function IsValidConceptualConstructionTypeElement (
id As ElementId
) As Boolean
public:
bool IsValidConceptualConstructionTypeElement(
ElementId^ id
)
member IsValidConceptualConstructionTypeElement :
id : ElementId -> bool
Parameters
- id ElementId
-
The ElementId to be checked.
Return Value
Boolean
True if the ElementId is an acceptable conceptual construction type ElementId, false otherwise.
Exceptions
Remarks
In the case that 'conceptualConstructionIsByEnergyData' is true, invalidElementId is also acceptable input.
See Also