DocumentExport(String, String, ICollectionElementId, DWGExportOptions) Method |
Exports a selection of views in DWG format.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool Export(
string folder,
string name,
ICollection<ElementId> views,
DWGExportOptions options
)
Public Function Export (
folder As String,
name As String,
views As ICollection(Of ElementId),
options As DWGExportOptions
) As Boolean
public:
bool Export(
String^ folder,
String^ name,
ICollection<ElementId^>^ views,
DWGExportOptions^ options
)
member Export :
folder : string *
name : string *
views : ICollection<ElementId> *
options : DWGExportOptions -> bool
Parameters
- folder String
-
Output folder, into which file(s) will be exported. The folder must exist.
- name String
-
Either the name of a single file or a prefix for a set of files.
If empty, automatic naming will be used.
If , throw ArgumentException.
- views ICollectionElementId
-
Selection of views to be exported. The set must contain at least one valid view.
- options DWGExportOptions
-
Various options applicable to the DWG format.
If , all options will be set to their respective default values.
Return Value
Boolean
True if successful, otherwise False.
Exceptions
Remarks
All the views must be printable for the Export to succeed.
It can be assured by checking the CanBePrinted property of each view.
Examplepublic bool ExportDWG(Document document, View view, string setupName)
{
bool exported = false;
IList<string> setupNames = BaseExportOptions.GetPredefinedSetupNames(document);
foreach (string name in setupNames)
{
if (name.CompareTo(setupName) == 0)
{
DWGExportOptions dwgOptions = DWGExportOptions.GetPredefinedOptions(document, name);
ICollection<ElementId> views = new List<ElementId>();
views.Add(view.Id);
exported = document.Export(Path.GetDirectoryName(document.PathName),
Path.GetFileNameWithoutExtension(document.PathName), views, dwgOptions);
break;
}
}
return exported;
}
Public Function ExportDWG(document As Document, view As View, setupName As String) As Boolean
Dim exported As Boolean = False
Dim setupNames As IList(Of String) = BaseExportOptions.GetPredefinedSetupNames(document)
For Each name As String In setupNames
If name.CompareTo(setupName) = 0 Then
Dim dwgOptions As DWGExportOptions = DWGExportOptions.GetPredefinedOptions(document, name)
Dim views As ICollection(Of ElementId) = New List(Of ElementId)()
views.Add(view.Id)
exported = document.Export(Path.GetDirectoryName(document.PathName), Path.GetFileNameWithoutExtension(document.PathName), views, dwgOptions)
Exit For
End If
Next
Return exported
End Function
No code example is currently available or this language may not be supported.
No code example is currently available or this language may not be supported.
See Also