ExternalDefinitionCreationOptions Constructor |
Constructs the options using a specified name and type.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ExternalDefinitionCreationOptions(
string name,
ForgeTypeId dataType
)
Public Sub New (
name As String,
dataType As ForgeTypeId
)
public:
ExternalDefinitionCreationOptions(
String^ name,
ForgeTypeId^ dataType
)
new :
name : string *
dataType : ForgeTypeId -> ExternalDefinitionCreationOptions
Parameters
- name String
-
The name of the parameter definition to be created.
- dataType ForgeTypeId
-
The identifier of either a spec or a category.
A category identifier indicates a Family Type parameter of that category.
Exceptions
See Also