MEPSectionGetCoefficient Method |
Gets the loss coefficient for the specified element id in this section.
Namespace: Autodesk.Revit.DB.MechanicalAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic double GetCoefficient(
ElementId elemId
)
Public Function GetCoefficient (
elemId As ElementId
) As Double
public:
double GetCoefficient(
ElementId^ elemId
)
member GetCoefficient :
elemId : ElementId -> float
Parameters
- elemId ElementId
-
The element id which can be duct segment, duct fitting , pipe segment and pipe fitting.
Return Value
Double
Exceptions
Remarks
For Duct, it is loss coefficient.
For Pipe, the loss coefficient is equivalent to the friction factor.
Loss coefficient is a number.
The unit type is UT_Number.
See Also