StairsLandingBaseElevation Property |
The base elevation of the landing.
Namespace: Autodesk.Revit.DB.ArchitectureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic double BaseElevation { get; set; }
Public Property BaseElevation As Double
Get
Set
public:
property double BaseElevation {
double get ();
void set (double value);
}
member BaseElevation : float with get, set
Property Value
Double
The base elevation is relative elevation against base elevation of the stairs to which the stairs run belongs to.
When setting this property the base elevation will be rounded automatically to a multiple of the riser height.
ExceptionsException | Condition |
---|
ArgumentOutOfRangeException |
When setting this property: The given value for height must be no more than 30000 feet in absolute value.
-or-
When setting this property: The height is less than half of the riser height of the stairs.
|
See Also