StructuralSectionGeneralLZ Constructor

Creates a new instance of Z Cold Formed shape.

Namespace: Autodesk.Revit.DB.Structure.StructuralSections
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public StructuralSectionGeneralLZ(
	double width,
	double height,
	double wallNominalThickness,
	double wallDesignThickness,
	double innerFillet,
	double bottomFlangeLength,
	double lipLength,
	double centroidHorizontal,
	double centroidVertical,
	StructuralSectionAnalysisParams analysisParams
)

Parameters

width  Double
Section width.
height  Double
Section height, depth.
wallNominalThickness  Double
Represents wall nominal thickness of rectangle.
wallDesignThickness  Double
Represents wall design thickness of rectangle.
innerFillet  Double
Inner Fillet - Corner fillet inner radius.
bottomFlangeLength  Double
Bottom Flange segment length.
lipLength  Double
Lip segment length.
centroidHorizontal  Double
Distance from centroid to the left extremites along horizontal axis.
centroidVertical  Double
Distance from centroid to the upper extremites along vertical axis.
analysisParams  StructuralSectionAnalysisParams
Common set of parameters for structural analysis.
See Also