StructuralSectionAnalysisParams Class

Defines common set of parameters for structural analysis.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.Structure.StructuralSectionsStructuralSectionAnalysisParams

Namespace: Autodesk.Revit.DB.Structure.StructuralSections
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class StructuralSectionAnalysisParams : IDisposable

The StructuralSectionAnalysisParams type exposes the following members.

Constructors
 NameDescription
Public methodStructuralSectionAnalysisParams Creates a new instance of StructuralSectionAnalysisParams.
Public methodStructuralSectionAnalysisParams(Double, Double, Double, Double, Double, Double, Double, Double, Double, Double, Double, Double, Double, Double, Double) Creates a new instance of StructuralSectionAnalysisParams.
Top
Properties
 NameDescription
Public propertyElasticModulusStrongAxis Elastic section modulus about main strong axis for calculation of bending stresses.
Public propertyElasticModulusWeakAxis Elastic section modulus about main weak axis for calculation of bending stresses.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyMomentOfInertiaStrongAxis Moment of Inertia about main strong axis (I).
Public propertyMomentOfInertiaWeakAxis Moment of Inertia about main weak axis (I).
Public propertyNominalWeight Unit weight (not mass) per unit length, for self-weight calculation or quantity survey.
Public propertyPerimeter Painting surface of the unit length.
Public propertyPlasticModulusStrongAxis Plastic section modulus in bending about main strong axis (Z, Wpl)
Public propertyPlasticModulusWeakAxis Plastic section modulus in bending about main weak axis.
Public propertyPrincipalAxesAngle Rotation angle between the principal axes and cross section reference planes.
Public propertySectionArea Cross section area.
Public propertyShearAreaStrongAxis Shear area (reduced extreme shear stress coefficient) in the direction of strong axis (Wq).
Public propertyShearAreaWeakAxis Shear area (reduced extreme shear stress coefficient) in the direction of weak axis (Wq).
Public propertyTorsionalModulus Section modulus for calculations of torsion stresses (Ct)
Public propertyTorsionalMomentOfInertia Torsional Moment of inertia (J, IT, K), for calculation of torsional deformation
Public propertyWarpingConstant Warping constant (Cw, Iomega, H)
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the StructuralSectionAnalysisParams
Top
See Also