PlaneCreateByOriginAndBasis Method

Creates a Plane object defined by the two orthogonal unit vectors and passing through the origin point supplied as arguments.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static Plane CreateByOriginAndBasis(
	XYZ origin,
	XYZ basisX,
	XYZ basisY
)

Parameters

origin  XYZ
Plane origin. Expected to lie within the Revit design limits IsWithinLengthLimits(XYZ).
basisX  XYZ
First of the two unit vectors that define the plane. Must be orthogonal to the second one.
basisY  XYZ
Second of the two unit vectors that define the plane. Must be orthogonal to the first one.

Return Value

Plane
Exceptions
ExceptionCondition
ArgumentException The input point lies outside of Revit design limits.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException basisX is not length 1.0. -or- basisY is not length 1.0.
ArgumentsInconsistentException The vectors basisX and basisY are not perpendicular.
Remarks
The parametric equation of the plane is S(u, v) = origin + u*basisX + v*basisY. The plane's normal is defined as basisX.Cross(basisY).
See Also